Welcome to the new Woodmann RCE Messageboards Regroupment
Please be patient while the rest of the site is restored.

To all Members of the old RCE Forums:
In order to log in, it will be necessary to reset your forum login password ("I forgot my password") using the original email address you registered with. You will be sent an email with a link to reset your password for that member account.

The old vBulletin forum was converted to phpBB format, requiring the passwords to be reset. If this is a problem for some because of a forgotten email address, please feel free to re-register with a new username. We are happy to welcome old and new members back to the forums! Thanks.

All new accounts are manually activated before you can post. Any questions can be PM'ed to Kayaker.

odbgscript v1.66.3 released...

Bugs/suggestions/scripts/... for OllyScript plugin
Locked
Epsylon3
Senior Member
Posts: 129
Joined: Fri May 26, 2006 5:10 pm
Location: France

odbgscript v1.66.3 released...

Post by Epsylon3 »

dont have added chinese recent improvements (if there are), because he didnt contact me... and dont find this version...

Added a new command : GOPI (Get Operand Information)

http://odbgscript.sf.net
hnedka
Junior Member
Posts: 14
Joined: Thu Mar 13, 2008 7:58 pm

olly crashing

Post by hnedka »

For some unknown reason, this nice plugin always crashes Olly when I try to run any application (without even running any script, all I neeed is to have this plugin in Plugin directory). I tried removing all other plugins and even starting with clear Olly without anything in ini file and still the same. Running Win XP SP 2, non-english version. Anyone have the same problem?

Edit: I found version 1.48 and it works OK.
Epsylon3
Senior Member
Posts: 129
Joined: Fri May 26, 2006 5:10 pm
Location: France

Post by Epsylon3 »

Which non english language ? Could you try it on a Windows Vista with similar language ?
hnedka
Junior Member
Posts: 14
Joined: Thu Mar 13, 2008 7:58 pm

Post by hnedka »

Czech version. I will try in Vista later and let you know.
Epsylon3
Senior Member
Posts: 129
Joined: Fri May 26, 2006 5:10 pm
Location: France

Post by Epsylon3 »

Thanks, could be the language, there is no problems with English and French versions...
hnedka
Junior Member
Posts: 14
Joined: Thu Mar 13, 2008 7:58 pm

Post by hnedka »

It runs fine on my Vista, but XP is the problem. Maybe it's because the system is too long without reinstall and too messed-up. I don't know.

But I probably found the bug:
http://img297.imageshack.us/img297/1120/ollyscriptke9.png

And this fixes it for me (code I added is bold and red):

Code: Select all

	if (debugevent && debugevent->dwDebugEventCode == OUTPUT_DEBUG_STRING_EVENT && debugevent->u.DebugString.nDebugStringLength>0
			[color="Red"][B]&& !IsBadCodePtr((FARPROC)debugevent->u.DebugString.lpDebugStringData)[/B][/color])
		MsgBox(debugevent->u.DebugString.lpDebugStringData,"");
Epsylon3
Senior Member
Posts: 129
Joined: Fri May 26, 2006 5:10 pm
Location: France

Post by Epsylon3 »

Thanks, i updated SVN version, so this fix will be in the next versions...
User avatar
SunBeam
Posts: 25
Joined: Mon May 15, 2006 5:54 am

Post by SunBeam »

Apparently EVAL+ASM command fails hardddd!! Here's code:

eval "MOV EAX,DWORD PTR SS:[EBP+FFFFAF84]"
asm eip,$RESULT

Fails with this error:

"Error on line X
Text: asm eip,$RESULT
Syntax error"
EXECryptor Add!ct
fr33ke
Posts: 109
Joined: Sat Jul 08, 2006 8:00 am

Post by fr33ke »

FFFFAF84 is not a number for Olly, 0FFFFAF84 is
<[TN]FBMachine> i got kicked out of barnes and noble once for moving all the bibles into the fiction section
Locked