Welcome to the new Woodmann RCE Messageboards Regroupment
Please be patient while the rest of the site is restored.

To all Members of the old RCE Forums:
In order to log in, it will be necessary to reset your forum login password ("I forgot my password") using the original email address you registered with. You will be sent an email with a link to reset your password for that member account.

The old vBulletin forum was converted to phpBB format, requiring the passwords to be reset. If this is a problem for some because of a forgotten email address, please feel free to re-register with a new username. We are happy to welcome old and new members back to the forums! Thanks.

All new accounts are manually activated before you can post. Any questions can be PM'ed to Kayaker.

serious bug in olly engine!

Found a bug in OllyDbg? Post a report here.
Locked
tibbar

serious bug in olly engine!

Post by tibbar »

if i do:

Assemble("JS 0x463BC7", 0x483B46, &am, 0, 0, errtext);

this returns me 0x78 0x7F

But!!!

0x463BC7 - 0x483B46 = 0x81 = 129 > 127!!

This doesnt happen in the Olly 1.10, only the engine on your site when i use it in my app...

Any ideas whats going wrong?

Many Thanks.
blabberer
Senior Member
Posts: 1535
Joined: Wed Dec 08, 2004 11:12 am

serious bug in olly engine!

Post by blabberer »

you mean the disasm.zip available in the main site ??
that version of disasm source is not current source it was of version 1.04 if i remember correctly if you want some source to look at try pvdasm by ben (he has released his source of the disassembler and is uptodate to match the compiled binary)
tibbar

serious bug in olly engine!

Post by tibbar »

yes version 1.04.

isn't the source from 1.10 available, seems a bit strange to keep buggy source available...

i guess i will have to fix it myself, as my project is built around the ollyengine now.
Locked