Welcome to the new Woodmann RCE Messageboards Regroupment
Please be patient while the rest of the site is restored.

To all Members of the old RCE Forums:
In order to log in, it will be necessary to reset your forum login password ("I forgot my password") using the original email address you registered with. You will be sent an email with a link to reset your password for that member account.

The old vBulletin forum was converted to phpBB format, requiring the passwords to be reset. If this is a problem for some because of a forgotten email address, please feel free to re-register with a new username. We are happy to welcome old and new members back to the forums! Thanks.

All new accounts are manually activated before you can post. Any questions can be PM'ed to Kayaker.

JIT Debug Launch Issue

Found a bug in OllyDbg? Post a report here.
Locked
Piers Plowman

JIT Debug Launch Issue

Post by Piers Plowman »

On my Win2k SP4 system I cannot use the Ollydbg as a system debugger as when it is set for this I only get errors on trying to open -aedebug.exe

I looked at the key at

HKLM\Software\Microsoft\WindowsNT\CurrentVersion\AeDebug\Debugger

and found the value to be

"C:\toolkit\OLLYDBG.EXE" -AEDEBUG %ld %ld

it does properly? parse the %ld %ld as the Process ID of the target process

Launching it from the commandline as ollydbg -aedebug <procid> also has the same error.

I tried removing the key and recreating it through the JIT options in Olly but the same key value is set.

Any ideas on what is wrong?

TIA
focht

JIT Debug Launch Issue

Post by focht »

Hi,

well that registry key looks fine.
First parameter is process id (PID) and second one is event handle (to be signaled if process is attached).

To test it from command line you need to supply both parameters, e.g.:

ollydbg -AEDEBUG <pid> <event handle>

To test JIT, write some simple program which forces unhandled exception.

Regards
Piers Plowman

JIT Debug Launch Issue

Post by Piers Plowman »

Thanks for your quick response!

I didn't realize that the second parameter was for the event handle. The application I was envoking the debugger from wasn't passing that parameter and if you launch it from the commandline as I did previously it gives that anomalous error regarding -AEDEBUG.exe

Perhaps the error handling for insufficient/improper command arguments can be made more clear in a future version.

Thanks again! :)
Locked