Welcome to the new Woodmann RCE Messageboards Regroupment
Please be patient while the rest of the site is restored.

To all Members of the old RCE Forums:
In order to log in, it will be necessary to reset your forum login password ("I forgot my password") using the original email address you registered with. You will be sent an email with a link to reset your password for that member account.

The old vBulletin forum was converted to phpBB format, requiring the passwords to be reset. If this is a problem for some because of a forgotten email address, please feel free to re-register with a new username. We are happy to welcome old and new members back to the forums! Thanks.

All new accounts are manually activated before you can post. Any questions can be PM'ed to Kayaker.

A Question - Zynamics Binnavi 5.0

Questions concerning tools (other than OllyDbg) - IDA Pro, SoftIce, member contributions, etc.
<b>NOTE:</b> You must <b>always</b> make sure you cannot find what you are looking for in our <a href="/collaborative/tools">Collaborative RCE Tool Library</a> before asking for <b>any</b> tools that can do this or that though!
Locked
User avatar
Aimless
Senior Member
Posts: 869
Joined: Thu Sep 13, 2001 3:11 am

A Question - Zynamics Binnavi 5.0

Post by Aimless »

Yes, I got that. Yes, from 'unofficial' sources, thank you.

For those of you who have used it, could you please tell me if the PATHFINDER plugin is working correctly? For me (WinXP running in a VM), everything, EXCEPT the Pathfinder plugin, works. That means, the pathfinder just does not pop-up. Whether its in the main modules tree OR the project modules tree (including direct selection of the binary, right-clicking and putting in PATHFINDER).

Any clues, anyone?

Have Phun
Blame Microsoft, get l337 !!
User avatar
Aimless
Senior Member
Posts: 869
Joined: Thu Sep 13, 2001 3:11 am

Post by Aimless »

Helllo--ooooooo!!!! Anybody have an idea of what's happening? Or rather, what's NOT happening?

Have Phun
Blame Microsoft, get l337 !!
username443
Junior Member
Posts: 9
Joined: Mon Jan 21, 2013 6:01 am

Post by username443 »

Isn't working for me either. Pathfinder does not launch. Plugin log window is empty. But a debug run shows something. If only I knew Java... Maybe something to do with pathing... Prolly the stolen version being incomplete. Filthy pirates...

Starting BinNavi 5.0.0 Build: 13 / 16391

C:\BinNavi>binnavi-dbg.cmd
Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: com/google/security/zynamics/binnavi/Gui/HotKeys
at com.google.security.zynamics.binnavi.standardplugins.utils.CDialogEscaper.<init>(Unknown Source)
at com.google.security.zynamics.binnavi.standardplugins.pathfinder.PathfindingDialog.<init>(Unknown Source)
at com.google.security.zynamics.binnavi.standardplugins.pathfinder.PathfinderPlugin.showPathfindingDialog(Unknown Source)
at com.google.security.zynamics.binnavi.standardplugins.pathfinder.PathfinderPlugin.access$100(Unknown Source)
at com.google.security.zynamics.binnavi.standardplugins.pathfinder.PathfinderPlugin$PathfindingAction.actionPerformed(Unknown Source)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.menuDragMouseReleased(Unknown Source)
at javax.swing.JMenuItem.fireMenuDragMouseReleased(Unknown Source)
at javax.swing.JMenuItem.processMenuDragMouseEvent(Unknown Source)


---edit---

And the 4th version does not find dynamic calls to resolve...
"Resolve calls!"
"Found 0 indirect calls"
Trololololol
There is a call eax in the first 10 fucking lines... Are you blind?
User avatar
Aimless
Senior Member
Posts: 869
Joined: Thu Sep 13, 2001 3:11 am

Post by Aimless »

Let's wait and see if some JAVA guru comes around to look at this...

Have Phun
Blame Microsoft, get l337 !!
username443
Junior Member
Posts: 9
Joined: Mon Jan 21, 2013 6:01 am

Post by username443 »

Dude, are you serious? Run the debug mode. Tell me if you have the same problem! I wanna know if this tool is usable for something and fix it...

And stop writing Have Phun, it aint 2001 no more...
User avatar
Aimless
Senior Member
Posts: 869
Joined: Thu Sep 13, 2001 3:11 am

Post by Aimless »

Yes. I do have the same problem.

And no, the program is not incomplete. I have the complete .MSI installer. So it seems to me, at least for the moment, the Zynamics Code, rather than the pirates releases.

Both the PATHFINDER and RESOLVEINDIRECTCALL don't work.

Though, the VISUAL COVERAGE works OK.

I'm already tinkering around. Let me see what else is needed.

I understand that the SPACES in the code, is not ESCAPED. Though, I don't see much happening because of that.

In the meanwhile, lets see if a Java guru can help here.

Have Phun
Blame Microsoft, get l337 !!
username443
Junior Member
Posts: 9
Joined: Mon Jan 21, 2013 6:01 am

Post by username443 »

By "same probelm" you mean that your cmd line output is exactly the same, ie
Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: com/google/security/zynamics/binnavi/Gui/HotKeys
at com.google.security.zynamics.binnavi.standardplugins.utils.CDialogEscaper.<init>(Unknown Source)
...
?

The .jar files seem to be obfuscated with yGuard.

Also, the scene rls has no .msi installer...
username443
Junior Member
Posts: 9
Joined: Mon Jan 21, 2013 6:01 am

Post by username443 »

Can I actually post code here from the soft in question without infringing on some shit?

---edit---

So, I actually found those sources uploaded! Wow!

Alright, CDialogEscaper.java inside of "plugins\com\google\security\zynamics\binnavi\standardplugins\utils\" look like this in Notepad.
http://pastebin.ca/2316678
I am looking specifically at CDialogEscaper because a content search for plaintext "Hotkeys" (from the debug error messages) gave it as the only relevant result.


Content search inside of an extracted binnavi.jar for "dialog argument can not be null" ( a string from CDialogEscaper.java ) delivers the obfuscated version, which (interestingly) lacks "import com.google.security.zynamics.binnavi.Gui.HotKeys;" in any form...
http://pastebin.ca/2316679

Eurika?
User avatar
Aimless
Senior Member
Posts: 869
Joined: Thu Sep 13, 2001 3:11 am

Post by Aimless »

That is probably for executing the plugin via a hotkey. I can understand if the hotkey fails and the plugin does not launch. But here, we directly execute the plugin by right clicking on the module and/or the project memory space, and running a PATHFINDER or RESOLVEINDIRECTCALLS does not do anything. And YET, running RESOLVEALLIMPORTEDCALLS runs perfectly.

So I don;t think the Hotkeys is the one.

Have Phun
Blame Microsoft, get l337 !!
Silkut
Senior Member
Posts: 579
Joined: Fri Mar 31, 2006 11:29 am

Post by Silkut »

username443 wrote:And stop writing Have Phun, it aint 2001 no more...
username443 wrote:Also, the scene rls has no .msi installer...
Then don't mention "the scene", it's dead since '98. :yay:
Please consider donating to help Woodmann.com staying online (here is why).
Any amount greatly appreciated. Thank you.
username443
Junior Member
Posts: 9
Joined: Mon Jan 21, 2013 6:01 am

Post by username443 »

The scene is dead cause DSL killed all the topsites? =P

Come on, if EMBRACE manages to steal/card the latest greatest BinNavi release from someone/Zynamics than the scene lives!

Image

But yeah, +ORC is dead...

-edit-

Man, this bug? is starting to itch in all the wrong places. I started to consider coding in Java for more background...
Locked