Welcome to the new Woodmann RCE Messageboards Regroupment
Please be patient while the rest of the site is restored.

To all Members of the old RCE Forums:
In order to log in, it will be necessary to reset your forum login password ("I forgot my password") using the original email address you registered with. You will be sent an email with a link to reset your password for that member account.

The old vBulletin forum was converted to phpBB format, requiring the passwords to be reset. If this is a problem for some because of a forgotten email address, please feel free to re-register with a new username. We are happy to welcome old and new members back to the forums! Thanks.

All new accounts are manually activated before you can post. Any questions can be PM'ed to Kayaker.

can't resize or add new section

First timers and new learners, this forum is for you. Please use the search function to see if your question has already been answered.
Locked
chitech

can't resize or add new section

Post by chitech »

Alo

I want to add funtionality to notepad (winxp). I have found where I want to jmp from and now I need a place to add my code. I use LordPe deluxe.

1. use .Code section -> not enough space :(

2. resize last section (.rsrc)
- set Vsize and Rsize to a bigger size.
- set flags to E0000060
- Sizeofimage changes automatic.

Now the program don't start -> Notepad.exe is not a valid win32 application.

3. Add new section -> same problem :(

What am I doing wrong. I have used the "search function" but can't find anything.

Please guide me....Thx :)

Chitech
DakienDX

Post by DakienDX »

Hello chitech !

I can't verify this on my own, since the WinXP Notepad fails to load some imports on Win98, but if you add a new section, you overwrite the start of the "Bound Imports" table in the header.

So one possibility would be resizing the .code section and correcting all affected pointers, or moving the "Bound Imports" table some bytes forward in the header and correcting the "Bound Imports" directory entry, so you've space for a new section.

I don't know why you can't resize the .rsrc section. I tried it and it worked. The program still showed my that it can't find some imports, but I think checking if a file is a valid Win32-PE file comes before trying to load imports. ;)
chitech

Post by chitech »

alo DakienDX

I forgot to "truncate at end of section" Me very bad :(

Thx DakienDX.....(everytime I post a tread u r the first person who answer my questions) :D


See u guys around

Chitech
Locked