Results 1 to 3 of 3

Thread: serious bug in olly engine!

  1. #1
    tibbar
    Guest

    serious bug in olly engine!

    if i do:

    Assemble("JS 0x463BC7", 0x483B46, &am, 0, 0, errtext);

    this returns me 0x78 0x7F

    But!!!

    0x463BC7 - 0x483B46 = 0x81 = 129 > 127!!

    This doesnt happen in the Olly 1.10, only the engine on your site when i use it in my app...

    Any ideas whats going wrong?

    Many Thanks.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    Super Moderator
    Join Date
    Dec 2004
    Posts
    1,486
    Blog Entries
    15

    serious bug in olly engine!

    you mean the disasm.zip available in the main site ??
    that version of disasm source is not current source it was of version 1.04 if i remember correctly if you want some source to look at try pvdasm by ben (he has released his source of the disassembler and is uptodate to match the compiled binary)

  3. #3
    tibbar
    Guest

    serious bug in olly engine!

    yes version 1.04.

    isn't the source from 1.10 available, seems a bit strange to keep buggy source available...

    i guess i will have to fix it myself, as my project is built around the ollyengine now.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. Vulnerability fix for bTree engine
    By Hex Blog in forum Blogs Forum
    Replies: 0
    Last Post: May 17th, 2013, 05:28
  2. GCB engine release.
    By Indy in forum Mini Project Area
    Replies: 35
    Last Post: February 28th, 2011, 22:40
  3. Encrypted execution engine
    By tom324 in forum Off Topic
    Replies: 2
    Last Post: August 27th, 2004, 11:58
  4. +Tsehp -- fravia search engine ???
    By Clandestiny in forum Advanced Reversing and Programming
    Replies: 2
    Last Post: January 18th, 2001, 08:50

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •