Results 1 to 3 of 3

Thread: Debugging a stack overflow - hardware breakpoints problem

  1. #1
    Fireice
    Guest

    Debugging a stack overflow - hardware breakpoints problem

    I'm trying to debug a stack overflow. I tried setting a hardware breakpoint at the location, but it doesn't fire. I know that the code gets executed, because I put some bad commands and it page faulted.

    I'm running XP SP1 on AMD Athlon 2800+.
    Are there any known issues with this setup? Any ideas how to diagnose the problem?
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    arjuns
    Guest

    Debugging a stack overflow - hardware breakpoints problem

    I am having the same problem........
    there is still something dfferent, I have read someone's tutorials about writting explit on stack,in his tutorial stack address begins from 21XXXX
    and in mine it is 002XXX and in shellcoding wehave to avoid nulls ..
    so please tell me how to write code for that address.
    thanks in advance
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  3. #3
    Fireice
    Guest

    Debugging a stack overflow - hardware breakpoints problem

    You need to return-to-libc, or in case of windows to system dll, jump to a command that will take you back to your code, like jmp esp, call esp, etc, anyone got ideas on the original topic?
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. Enthusiastic question about this stack overflow.
    By ptr0x in forum Advanced Reversing and Programming
    Replies: 1
    Last Post: March 17th, 2014, 01:21
  2. # DS/FS is under hardware breakpoints
    By nezumi-lab in forum Blogs Forum
    Replies: 0
    Last Post: January 7th, 2009, 01:35
  3. hardware breakpoints
    By 5aLIVE in forum OllyDbg Support Forums
    Replies: 1
    Last Post: August 19th, 2005, 09:28
  4. About hardware breakpoints
    By thomasantony in forum Bugs
    Replies: 16
    Last Post: February 18th, 2005, 12:16
  5. hardware breakpoints on IO ?
    By Anonymous in forum OllyDbg Support Forums
    Replies: 1
    Last Post: December 1st, 2002, 22:18

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •