Results 1 to 14 of 14

Thread: softice help

  1. #1
    god
    Guest

    softice help

    someone accidently deleted my last post

    but srsly i have bin everywhere tried every patch, read ever FAQ..i need your help.

    my error is:
    Error code 31, a device attached to the system is not functioning, please check the even viewer for more information.

    PLEASE HELP ME!
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    Well ... if you bought the thing, you should have enough info to persuade compuware to give you what info you need to get support from them.

    Furthermore, a search on google revealed som possible options. Have you tried following those?

    And remember, posting in the right forum usually keeps you on the good side of the mods ... this belongs in the tools section. Do yourself a favour next time you post.

    Fake

  3. #3
    Naides is Nobody
    Join Date
    Jan 2002
    Location
    Planet Earth
    Posts
    1,647
    Now I am an atheist for sure.
    Last edited by naides; January 20th, 2006 at 13:27.

  4. #4
    god
    Guest
    lol sorry! i thought i was newbie hence in d newbie forum

    mbe u can move it 2 the tools section

    i have read through everything in google and nothing is working..

    maybe if you can give me some ideas to try?

    should i downgrade to 3.1?

    Thanks.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  5. #5
    god, a few points:

    1. Respect the fact that the mods are all-knowing and all-powerful. If your last thread was deleted it was probably for a good reason. Coming back with the same question but louder serves only to tighten the noose around your neck.
    2. Screaming 'HEEEEELLLPPP MEEEE!!!!!11111' doesn't make us want to help. It just makes us want to close the window.
    3. Saying 'I've read every FAQ and I'm still stuck' is about as useful as saying nothing, and it appears only as a superficial way to bypass the 'do your own research' rule we have here. I could list fifty more pieces of information that you could give us without any real effort on your part, that would help us help you and would help you to gain more credibility - a commodity you seem to be running dangerously low on, to be honest.

    I know how frustrating it can be when nothing works and the solution doesn't seem to exist, but if a solution does exist you probably need to work smarter and not harder.
    I don't know about you but I get 134 results when I Google SoftICE+"Error Code 31". Granted, most of these results will lead to threads like this where we tell you to go away, but they only exist 'cause we're sick of answering the same questions.
    If you find a recurring theme that you don't like, construct a (creative) 'exclusion clause' in your search. Similarly, if you see something promising that you'd like to be expanded on, fire up a new instance of Google and do what needs to be done. The truth is out there, so find the best way to find it.

    Now if you still can't work it out after doing some exhaustive work, come back here with a better attitude and we may be more helpful. This means don't come back today or tomorrow, but when there's nothing left to read.
    If you do come back, don't just say 'I'm still stuck!', but give us a list of anything and everything that's relevant: What versions of everything you have, when went right, what went wrong, what other people are saying about your error code etc.

    Perhaps the most important fact about SoftICE these days is that it's dying a death (and has been since XP/2000 became popular). My rule is 'use SoftICE if and only if you need to use SoftICE'. This means not using a sledgehammer to crack a nut: Unless you're working within kernel-mode, OllyDbg is the superior tool in every way I can think of. If you think you need SoftICE just because the tutorials you chose to download are using it then you're wrong on two counts. Firstly, anything (user-mode) SoftICE can do, OllyDbg can do better and secondly, if your turorials are using SoftICE they're probably years and years old anyway.

    Regards
    Admiral

  6. #6
    god
    Guest
    hey.

    when i google SoftICE+"Error Code 31" in google i get 0 results and heres a screenshot i just uploaded!

    http://img75.imageshack.us/img75/7968/screenshotsofticeerrorcode4iz.jpg

    so you didnt even try searching!! or you would know!!

    you have to search: SoftIce "error code 31" - and I have looked through the links! otherwise y would i be here!!??

    i always DO get to forums like this, but in MOST of them no solution is posted to my error.

    if you know how to fix it, instead of writing an essay why you aren't helping me, why not just tell me a few things to try!!??

    this was my last resort!

    so someone please help me.

    EDIT: browsing through the support section of compuware and i found this:

    The second possible "trick" would be what is called the NTSymbols trick.
    The steps for this are as follows:


    1. Create a correct NMS file for ntoskrnl. See "Translating system files" below.
    2. Place the NTSYMBOLS=ON keyword on a separate line in winice.dat.
    3. Add the symbols to the list of symbols to load at start. See "Adding files to start" below.

    That should solve nearly even problem encountered with a hot fix or service pack.



    TRANSLATING SYSTEM FILES -

    1. Be sure you have the correct symbols for your service pack and OS from the Microsoft web site or from the hot fix download zip file.

    NOTE: The example below is for ntoskrnl but the steps should be done on any system file you plan on translating.

    2. Find the correct ntoskrnl.exe for you machine. To do this right click on ntoskrnl.exe and select properties. Then select the version tab and then the original file name view.

    3. If the original file name was something other than ntoskrnl.exe then copy and rename the copy of ntoskrnl back to its original name.

    4. Copy the ntoskrnl.dbg (or pdb) that matches the original ntoskrnl.exe into the same directory as the exe.

    5. Open SoftICE symbol loader.

    6. Open the ntoskrnl.exe and translate the executable.

    7. If the exe was renamed due to the original file name then rename the resulting nms file back to ntoskrnl.nms

    8. Add ntoskrnl.nms to your list of symbol files to load at start using the SoftICE init settings dialog.

    ADDING FILES TO START -

    1. Open symbol loader.

    2. From the edit menu choose "SoftICE initialization settings".

    3. Go to "symbols" in the left side tree.

    4. Use the add button and navigate to the nms file that you made and add it to the list.

    Keywords: .net server, XP, Crash, Hang, SP, Latest, Version
    Last edited by god; January 21st, 2006 at 22:06.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  7. #7
    How about you give up your "god like attitude" and learn how to do something like basic searching.

    If "softice + error code 31" doesn't give you anything, how about you use your brain, instead of whinning and try some other combinations.

    "softice + error 31" gave 40,400 hits.

    http://www.google.com/search?hl=en&lr=&q=softice+%2B+error+31&btnG=Search

    and this one:

    http://codingforums.com/showthread.php?p=394317#post394317

    Several of which mention "error code 31" right on the excerpts from the first page of choices.

    For example this one:

    http://www.daemon-tools.cc/dtcc/t8623-error-code-31.html

    How about you get down off your high horse and get to work or just go away.

    Regards,
    JMI

  8. #8
    god
    Guest
    How about ive already looked at them!!

    ive tried the latest versions of those files but hey! nope!

    JMI at least u posted some results, the other guy came across as jst "im too good to help you"

    can you please list the files i need to retrieve symbols for.

    someone said the previous tutorial on this site was outdated.

    Thanks!
    Last edited by god; January 21st, 2006 at 22:23.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  9. #9
    Teach, Not Flame Kayaker's Avatar
    Join Date
    Oct 2000
    Posts
    4,048
    Blog Entries
    5
    Look buster, you waltz in here to ask a question and you've been doing everything wrong since. Now you're taking potshots at our members. These kinds of personal attacks will not be tolerated, no ifs ands or buts! If you had any familiarity with this place, for one you'd know how to ask a question. For another, you'd know "im too good to help you" is a ridiculous statement aimed at our most helpful members. Why don't you just shoot yourself in the foot?

    Now, this isn't about flaming and it isn't about trolling. If you still want, it CAN be about helping with your problem, but you're going to have to start to listen and help yourself. Your first post was deleted more out of disgust than anything I suppose. You were starting to post within minutes, meaningless pleadings, shouting in CAPS, and whining to a specific member to help plsss!

    The point people are trying to make is that you need to make a COMPLETE, ACCURATE description of your problem before anyone can try to help. This is no different from any other real life situation.


    I'm not bringing these up to flame, but I replied to your earlier posts,

    The reason no one is giving you the answer is that there is no ONE answer to your problem. Plus, you're not really helping yourself by giving vague descriptions of the problem.

    >>now it freezes on bootup - it says successfully loaded icepacks symbols...something on those lines..

    That's pretty vague. What are icepacks symbols? No such thing afaik. Instead of "something on those lines", tell us *exactly* what the error message is, it could be important.

    >>i just tried the driver patch

    What driver patch? If you read the several other threads on Softice + XP installation problems, you know about replacing osinfo.dat and osinfob.dat with the updated XP versions. Is that what you mean, or did you use some other patch/hack that some people do to their ntoskrnl?


    From your latest post,
    >>ive tried the latest versions of those files but hey! nope!

    Again, what files are you talking about?


    You have never once mentioned if you installed the updated osinfo.dat files, probably the most important thing to do with XP. You said you read "everything" so maybe you did. But WE don't know that, and can't eliminate it as a problem.

    At this point I'm going to make the dangerous assumption that you've tried reinstalling carefully, have set up your mouse and video settings properly, and have tested your display adapter and gotten an OK message?

    You obviously finally found out about using NTSYMBOLS=ON, mentioned in several threads on this board as well as the official document you found. At least that's a postive step.


    EVENT VIEWER
    The CPTHOOK driver was not available. CPTHOOK must be running for SoftICE to function.

    If cpthook isn't loading, this is probably either a problem with the osinfo.dat files, which contain among other things XP specific offsets for correctly loading symbols. Or you don't have the symbols properly loaded.

    You also haven't mentioned if you've downloaded the latest symbol files from the MS site and converted them to .nms files. Take note that if you use Symbol Retriever to connect to the MS site you may need an updated symsrv.dll from the latest WinDbg package if you have problems connecting. This is carefully outlined in other threads on this forum.


    So, why don't we take a step back and you bring us up to date on exactly what you've done so far, in terms of updated files, changes you've made to the winice.dat file, and whether you appear to have downloaded the correct symbols for your system? Include your processor type and video card make.

    That is, if you're still looking for help..

    Kayaker

  10. #10
    hadicol
    Guest
    from newbie to newbie:
    read admiral's last paragraph
    why bother with all this when you can use ollydbg free and easy?
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  11. #11
    god, I'm sorry if I came across as condescending. It wasn't my intention to offend or belittle you, but I certainly don't take any of it back.
    If you choose not to take any of my advice (regarding your behaviour or the use of OllyDbg), that's your prerogative, but biting the hand that feeds you is never the best idea.

    The reason everybody is merely guiding you but not giving you the answer is that nobody knows the answer off the top of their head. I'm sure many of us could come up with a solution given time (not least Kayaker) but I don't think anybody's prepared to go out and catch a fish to give to you.

    Not an 'I told you so', just as a means of clearing up notation: Jamming a + between two phrases without any spaces is equivalent (according to Google's string parser) to concatenating the strings (with a space). Clearly this isn't desirable in this case. So when I say

    SoftICE+"Error Code 31"

    you should really be thinking

    SoftICE [and] "Error Code 31"

    Normally, one would use quotes to delimit their search string, but quotes being part of the string, I needed some new notation. I'd have thought you'd have the sense to work out how to interpret a simple conjunction without getting flippant.
    And of course, I did 'even try searching'. The 134 figure wasn't pulled out of nowhere - it's the number of results I get with my Google language settings. I think there are 145 if you search in all languages.
    What worries me is that after so fervently asserting that you've looked at everything on the face of the earth, you managed to come up with the NTSYMBOLS find.

    Now if we can get back to the problem in hand, read Kayaker's post carefully. He's our resident SoftICE authority. You managed to paste Compuware's proposed panacea to us but you never said if it worked or, if it didn't, gave any details.
    Also, could you at least tell us why you don't like OllyDbg?

    Regards
    Admiral

  12. #12
    Please stop the madness.


    I will tell you how to fix the problem but you are not going to like it.

    Format your hard drive. Check the clean disk for MBR virus.
    Load your windows back on it.
    If you have Driver Studio 3.2 install it.
    SoftIce should have already be installed because it is included in Driver Studio 3.2.
    If it is not installed, start all over again but, just install Driver Suite and then install SoftIce that has all the current support for XP. (Dont ask me the version, I am too lazy to check)
    Dont let SI automatically start.

    OK, start SoftIce. No errors? GREAT.
    Errors? Shit, This would not happen if you had the CURRENT version of DS 3.2 that you PAID for but, you dont so now you have big problems.
    Those problems come from the fact that you are using shit that was released into the "wild".

    I wont even begin to explain why the shit you find in the "wild" is crap.

    Now, the infamous error 31. SoftIce does not have an error 31.
    Windows has an error 31 which says "a device attached to the system is not functioning". Dont ask me how to fix it, I dont care about this.

    If you want to fix the error 31, open you Device Manager and find out what friggen device has the fucked up drivers.

    Entender?

    OBC
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  13. #13
    *Format your hard drive. Check the clean disk for MBR virus.
    *Load your windows back on it.
    Or install it in vm.
    Clean windows to test any software!!!!!!!
    This should put it in the faq.
    esther


    Reverse the code,Reverse Your Minds First

  14. #14
    god
    Guest
    *- recently formatted...have nod32...virus check every week. checked again jst to make sure.
    *- i dont have illegal copy of ds - i got a copy from school - software development class

    gimme a sec i will update what ive tested
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. to softice or not to softice
    By WaxfordSqueers in forum Tools of Our Trade (TOT) Messageboard
    Replies: 19
    Last Post: December 31st, 2007, 17:41
  2. softice help
    By PETER in forum Tools of Our Trade (TOT) Messageboard
    Replies: 2
    Last Post: September 11th, 2002, 06:31
  3. Doing it without softice
    By blink4me in forum Advanced Reversing and Programming
    Replies: 8
    Last Post: July 5th, 2002, 23:32
  4. softice
    By skyman in forum Tools of Our Trade (TOT) Messageboard
    Replies: 2
    Last Post: March 21st, 2002, 01:52
  5. softice
    By Dan in forum Tools of Our Trade (TOT) Messageboard
    Replies: 1
    Last Post: October 30th, 2001, 00:33

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •