Results 1 to 3 of 3

Thread: lida error

  1. #1

    lida error

    Hello. I have trouble with lida (Linux Interactive DisAssembler) when i try open some program in lida. I see text : Jumping to entrypoint 0xxxxxx. And then error
    0xxxxxx not found in address range. I use knoppix DVD 4.00 installed in hdd. Have anyone any tips ? thx
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    Hi Goblin !,

    i have had the same problem when i switched to debian the reason behind is explained on the sourcforge help forum for lida:

    basically it is the mmap call that causes the problem (simple stupid )

    see here how a solution if that is really your problem:

    You can't MAP_SHARED a file opened in readonly mode. Using MAP_PRIVATE works fine.

    lida_back.c:724 image = mmap(0, tmpStat.st_size, PROT_READ, MAP_SHARED, fTarget, 0);
    should be
    lida_back.c:724 image = mmap(NULL, tmpStat.st_size, PROT_READ, MAP_PRIVATE, fTarget, 0);

    Many valid pointers look like negative integers. mmap errors are exactly equal to -1.

    lida_back.c:724 if ((int) image < 1) return (-1);
    should be
    lida_back.c:724 if ((int) image == -1) return (-1);

    from what i know lida is frozen as it is, it is a quickhack that grow huge it is beeing completely redeveloped as a native C/Qt/KDE app to solve the several gui quirks and finally leave perl out. i have no idea when a new version will appear tough

    i hope that addressed your problem?

    cheers and happy disassembling ,


  3. #3
    Thank you very much. All working now.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. error on WinXP
    By k19 in forum The Newbie Forum
    Replies: 9
    Last Post: June 8th, 2005, 07:36
  2. error in ollyscript
    By britedream in forum OllyScript Plugin
    Replies: 1
    Last Post: November 19th, 2004, 05:16
  3. New OllyScript error!
    By Anonymous in forum OllyScript Plugin
    Replies: 4
    Last Post: May 25th, 2004, 21:15
  4. upx unpack error
    By resuraha in forum Malware Analysis and Unpacking Forum
    Replies: 1
    Last Post: January 23rd, 2004, 14:53
  5. DilloDumper error?
    By dlt_ in forum The Newbie Forum
    Replies: 7
    Last Post: November 6th, 2003, 12:08


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts