I have tried in vain to find the solution to this problem myselfl.

A little history, I had DS3.01 installed and running well on XP Home + SP1,
then one day it decided it no longer wanted to display the console. I can get it to work again by installing a fresh OS and reinstalling DS.

Along comes SP2 which I want running regardless of how desparate I am to get DS up and running. I have downloaded the most recent version of osinfo.dat and ntoskrnl.nms and set NTSYMBOLS=ON in winice.dat. I've also applied the DS30SP2.DAT update.

Launching softICE cause the mouse to freeze, although it works in the console. The console accepts keyboard input as expected. Upon exiting softICE the the mouse pointer remains static and the keyboard only seems to respond to Ctrl+D or numlock keys, capslock light remains off.

I think the problem lies in the error messages displayed in the console, though I can't seem to find an answer on this forum or elsewhere.

The errors are all API hook failures: MiMapViewOfImageSection
MiUnMapViewofSection
MiAddValid PageToWorkingSet
KebugCheck2
MiCopyOnWrite
UhciInsertQh
UhciUnlinkQh
USBPORT_AlocateUSBAddress

Most of the above hint at keyboard and mouse related funtions.
My question is how do I fix this? My keyboard is PS/2 and my mouse is USB using a PS/2 adapter.

Below these messages I see
NTICE: NTRaiseHardError found at index 00b6
IntOE fault in SoftICE at address F2471053 offset 00092D8F Fault Code 3B030000.

Selecting the different combinations of the troubleshooting options didn't help.

BTW. I have tried OllyDbg as an alternative, with erratic results. Perhaps I'll save that for another thread.

I sincerely hope someone can help me in reaching a solution on this one as it is really annoying me.

Thanks for any help or advice.

5aLIVE.