Results 1 to 5 of 5

Thread: Sentinel problems I think

  1. #1
    MTB
    Guest

    Angry Sentinel problems I think

    Ok
    Here are the details. Target T A S a thermal model program similar to femap. Finally jumped and NOPed all the appropriate tests (yes there are alot).

    Program starts up, I can save and export over 300 nodes ( demo limit ), no nasty demo messages etc.

    However when I select any option the save and save as button is greyed out!!!

    Does anybody have a clue as to what is going wrong here? Other than reversing error? I suspect a hidden check somewhere without an error message?

    Currently using IDA and w32dasm as my tools, I have access to si but am shying away from it because of complexity.

    Thanks
    MTB
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    Teach, Not Flame Kayaker's Avatar
    Join Date
    Oct 2000
    Posts
    4,081
    Blog Entries
    5

    Re: Sentinel problems I think

    Hi MTB,

    This sounds like a menu reversing problem. The Save menu item is disabled, the 1st thing to do is ungray it. Often this is controlled by a GetMenuItemID / EnableMenuItem API call sequence. What you can do is run an API monitor on the various Menu API's and see what's being used to control displaying the menu bar.

    You can usually do a crude patch so that all menu items are enabled, but it's better to find the exact location where the decision is made to enable or disable the Save item. If you do find a flag that determines this, it may also lead back to other code that determines the functionality of other parts of the program. Enabling the menu item control is no guarantee of it being linked with the code to actually execute the function, but it's usually the 1st step. A true crippled demo may not even have the code, in which case you're generally stuck.

    There is really no other solution than to use Softice. You must learn to use this tool to its utmost as it is the only way to seriously reverse. We did a mini-project on enabling menu items a while back which included finding the menu code once you've enabled the menu item by tracing its WM_COMMAND message when selected.

    The best explanation of the whole process I've seen is Clandestiny's summary of that project, which I've attached as a zip file. That should give you a good starting point to get playing with Softice

    The original project is at

    http://www.woodmann.net/forum/showthread.php?threadid=126

    Let us know if this is what you need.


    Hey, Clandestiny. I "found" this on my hardrive while looking for notes on the question, and realized it had never been published! That's terrible, this is a good reference tut. I think you should post it at the main site, I mean it was spawned here, why should the knowledge we get out of the project forum lay buried in old messages that few are likely to read?


    Cheers,
    Kayaker

  3. #3
    Teach, Not Flame Kayaker's Avatar
    Join Date
    Oct 2000
    Posts
    4,081
    Blog Entries
    5
    Hmm, upload didn't seem to work with Opera. Trying again with IE.

    Nope, still a problem. I caught the error message this time:

    Warning: Unable to create '/usr/local/plesk/apache/vhosts/woodmann.com/httpdocs/vbulletin/upload/tmp/mixvibes_tut.zip': No such file or directory in /home/httpd/html/upload/admin/functions.php on line 1603

    Warning: Unable to move '/tmp/php2VDbw2' to '/usr/local/plesk/apache/vhosts/woodmann.com/httpdocs/vbulletin/upload/tmp/mixvibes_tut.zip' in /home/httpd/html/upload/admin/functions.php on line 1603


    Help! ISP magicians Woodmann and Tsehp

  4. #4
    Thanks for the compliments Kayaker

    Always meant to send that tut over to +teshp to put up on the main site... But being the perfectionist that I am, I kept waiting to find the time to polish up a few details ;-) ...And I kept waiting...And waiting... And then I got involved in new projects and forgot all about it.

    As they say, better late than never...so here it is. I'll try to u/l it if the board will let me. If it won't, feel free to email me MTB and I'll send it to you direct.

    Cheers,
    Clandestiny
    Attached Files Attached Files

  5. #5
    MTB
    Guest

    Talking

    Thanks Kayaker and Clandestiny. The tutorial is just the thing I needed!!!!

    BTW outside of crackz's site is there any other good repository of tutorials that I should be looking at? I am primarily looking for Sentinel and HASP dongle tutorials / information. It amazes me at the expensive software that uses such a lame protection scheme. Especially the JNZ followed by "Dongle not found or running in demo mode etc" message. It doesn't require a lot of reversing skill to get around this stuff.

    So onward to start learning how to use Softice! Do you recommend any particular version over another. Currently running window$ 98SE.

    Thanks Again
    MTB
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. having problems!!
    By bar891 in forum The Newbie Forum
    Replies: 2
    Last Post: October 30th, 2008, 19:07
  2. More problems with XP SP2...
    By dELTA in forum Off Topic
    Replies: 13
    Last Post: August 28th, 2004, 10:12
  3. some little problems
    By Crono in forum OllyDbg Support Forums
    Replies: 2
    Last Post: October 31st, 2003, 01:54
  4. IDA problems (or problems with me)?
    By stanks in forum Tools of Our Trade (TOT) Messageboard
    Replies: 6
    Last Post: June 6th, 2001, 11:55
  5. UNP problems
    By mike in forum Tools of Our Trade (TOT) Messageboard
    Replies: 3
    Last Post: April 18th, 2001, 11:27

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •