Results 1 to 5 of 5

Thread: Haspid change

  1. #1

    Haspid change


    I own a hasp4 M1 dongle.
    Last week, i tried to modify the haspid
    Using the very good 'undocumented hasp by bajunny', i wrote a C program that allow me to write the location 0 and 1
    This locations contains a copy of the haspid

    After a seccessfull value change with the C program, when i use haspedit to read the haspid, it did not change

    Using, my C program, i can read the new value on the location 0 and 1.

    Does anybody have any clue, suggestions?

    Is there another location where the haspid is stored?
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    So, try reading another known value (like location 20), then read it with haspedit. Make sure it is reading properly. (They should give the same value)
    If this fails, you are not properly accessing the HASP dongle.

    Next, if that works, write down the value on paper (notepad). Then try writing a value to 20. Then read in haspedit, if it writes, then your problem is with writing to the 0 and 1 locations, if it fails, then your problem is your writing to the dongle.

    Make sure you are not using an emulator, as they will use persistent memory and not let you change the value.

    Lastly, you could post your code and I can take a look at it later.

  3. #3
    I can write a value to location 20 without any problem, and i can read it back using haspedit without any problem.
    I think, my writting subroutine is working correctly.

    I also can write a value to location 0 and 1 and read it back correctly with my soft.

    I think my reading subrountine is ok because first time i read this location i read the haspid value.

    After writing this location i read the value i wrote.

    I was wondering if these locations were not only a COPY of the haspid that may be progrmmed in the ASIC at the factory stage?
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  4. #4
    bajunny seemed to be pretty confident that you could change it using only the write command.

    Anyhow, are you erasing before you write?
    I don't know what else it could be since your code seems to work. Are you using/have you compared with bajunny's code?

    It *is* possible that they are a copy of the HASPID, the real question is what does the program see when you are using that dongle? Does it see the value you wrote or the value that haspedit gives you? (Debugging required)

  5. #5
    I tried both : erasing before writing, and writing directly but same results

    bajunny in his study used a Memo-hasp i think, i am using a Hasp4 maybe there is a difference in the asic, that now store the haspid?

    Unfortunatly, the software see the real haspid, and not the one that i wrote.

    If i get the chance to have access to a memo hasp, i will try my soft on it to see if the haspid change.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. can i change EIP when debug?
    By lg888 in forum OllyDbg Support Forums
    Replies: 11
    Last Post: August 23rd, 2007, 10:47
  2. MAC change - spoofing
    By Ja187 in forum Off Topic
    Replies: 2
    Last Post: December 14th, 2005, 18:45
  3. Hey i need to know how to change this please guys.
    By tyler in forum OllyDbg Support Forums
    Replies: 2
    Last Post: October 24th, 2004, 04:38


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts