Results 1 to 4 of 4

Thread: "Access Violation" using RTA

  1. #1

    "Access Violation" using RTA

    I'm trying to use RTA to overwrite some asm permanently, and change it in the exe. When I get to a certain part of the code, RTA either crashes, or says "Access Violation" and I have to close the whole thing via task manager.

    I'm using this version of RTA:

  2. #2
    Not sure what your issue with RTA is, but you can get the same functionality with OllyDbg

    Here are the steps:
    - open the file in ollydbg
    - right-click on code you want to modify -> 'Assemble'
    - put your replacement instruction (rinse and repeat)
    - when done, right-click in CPU window -> 'Copy to executable' -> 'All modifications' then select 'Copy all'
    - In new window right-click -> 'Backup' -> 'Save data to file'
    - Done
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  3. #3
    Thanks, that worked.
    Last edited by Aquatic; September 12th, 2008 at 17:20.

  4. #4
    even simpler, you may use hiew

Similar Threads

  1. Replies: 0
    Last Post: February 13th, 2014, 07:42
  2. how to generat "1" instead of "uncounted" license
    By joyung in forum The Newbie Forum
    Replies: 38
    Last Post: April 10th, 2012, 03:57
  3. Replies: 4
    Last Post: May 28th, 2009, 13:02
  4. Replies: 1
    Last Post: December 14th, 2007, 13:35
  5. Replies: 2
    Last Post: June 28th, 2006, 13:46


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts