Results 1 to 13 of 13

Thread: "Time Hasp Battery Dead!" ???

  1. #1
    chefo
    Guest

    "Time Hasp Battery Dead!" ???

    Hi guys,

    I am using the HASPHL'2007 dumper/emulator for a program I used before. It was working fine until I ended up one day with a "Time Limit Expired" message. So far - so good. I started the EDGE tool, entered the passwords and a new time period - three months more, copied the generated code and updated the license in the emulator. The new message from the program was: "Time-hasp Battery Dead!".

    If I turn back to the original dump and adjust the system clock back in time everything works just fine but I don't like it this way.

    Any suggestions? Please?

    Thanks!
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    Yes! First suggestion... Read the Friggin FAQ, like you were told to do on the way in and as is written under your signature!

    Second, first YOU do some research on you own question. Our Rules require YOU "search," both here and on the net for potential answers to YOUR problem, before you post a question here.

    If you have done ANY searching on the issue of a "Time-hasp Battery Dead" warning, nothing you have posted so far would confirm that you have done so.

    So FIRST, YOU go look and then post what YOU found and then ask whether you are on the right track. Otherwise, it just looks like you are too lazy to do some of your own work of seeking answers to your questions, other than asking others to "give" you a solution. We expect more than that of the posters here.

    Regards,
    JMI

  3. #3
    ::[ Reverse Engineer ]:: OHPen's Avatar
    Join Date
    Nov 2002
    Location
    .text
    Posts
    399
    Blog Entries
    5
    @JMI: i should do a photo of my face when i see a new user with one post and the text it wrote contains a certain combination of "emulator", "dumper" and "hasp". Would look something like this probably :

    http://elperro1970.files.wordpress.com/2007/09/sick-dog.jpg

    Maybe some of you guys understand my opinion about that topic...
    Last edited by OHPen; February 22nd, 2008 at 03:46.
    - Reverse Enginnering can be everything, but sometimes it's more than nothing. Really rare moments but then they appear to last ages... -

  4. #4
    chefo
    Guest
    Thanks guys a lot for making such effort answering my post, I really appreciate it!

    I am dealing with HASPs more than an year yet, I have read a lot, including the FAQ of this forum, as well as many others, spent countless sleepless nights searching google and more... I successfully dealt some minor issues in my emulation…. until I faced this problem which I could not solve until now. It was a hard decision I made to post here for help.

    After all this I am still considering myself as a "newbie" in the matter, so I posted a "newbie" question in the "newbie" forum. What is wrong with that? If I could find some solution myself I would for sure use my own tools to emulate the key, not these you offer in your website, I then I wouldn't call myself a "newbie". And what is the idea of writing tools to be used by the other people without supporting the users by any way?

    I wonder what is the idea of having such forum if not helping each other saving time through sharing the experience we have, do we all have to discover the hot water by ourselves?


    I promise that I have read the FAQ and tried to use the Search to answer my question.

  5. #5
    Well allow me at attempt to clarify the situation for you. Everyone starts out as a Newbie and all of us are Newbie's on some issues related to reverse code engineering. None of us knows "everything" about "everything."

    That said, there is both a qualitative and quantitative difference between being a "Newbie" and asking a question in the "Newbie Forum" in the appropriate form and containing the appropriate information. We even went to some trouble to both provide some guidance in the FAQ and to call attention to the need for "new" posters to actually read it's contents BEFORE they posted.

    Your initial post strongly indicates that you failed to meet that requirement before you posted, and there is nothing in anything you have posted so far which indicates you are either familiar with the contents or that you have attempted to follow it's requirements. We, of course, have no way of knowing what you may have done before you post here, unless you tell us what you have done to attempt to solve your own problem.

    If you had spent any time reading posts in the Forums here, you would/should have been familiar with both these requirements AND that you should indicate what YOU had done to try to help yourself before you posted here.

    Essentially all you initially told us is that you used some ready made tools to change the "time limit" on your dongle and that it works if you set back the system clock but "you" don't like it that way! You reported that initially you got a "time limit expired" message, then after your additional three months time limit you added, you got a "Time-hasp Battery Dead" message, which you could fix by turning back the clock.

    With this limited information, you were asked to state what YOU had done to try to find the answer to this problem. It is OBVIOUS to anyone looking at you initial post that you did not say YOU had done ANYTHING to try to find the answer to that issue!

    Just so you don't misunderstand again, I asked you to tell us what YOU had done to investigate the issue of the meaning of the "Time-hasp Battery Dead" message, when you knew the battery was not really dead, and to tell us what you may have done to investigate how you might solve that problem "other than turning back the clock."

    The "Point" of these comments is that these are "subjects" which you should have investigate "on your own" through searching both here and on the net for answers. You are not being criticized for not "knowing" all the answers. To the extent that you are being criticized, it is about your failure to tell us what you actually did "to attempt to help yourself" beyond asking for the answers here.

    It is NOT important to us that you don't know the answer. That is something EXPECTED when posters ask questions here. What IS important to us, is that YOU not only do the "initial" work of attempting to find the answer to "your question," but that you give us sufficient information about what YOU have done to try to find that answer that we can actually tell whether or not you HAVE actually made an effort and, if so, whether you appear to be looking in the right area to find it.

    It is not really as helpful to actually give someone the answer to a question as it is to assist them in finding the answer on their own, with a little guidance. If someone just tells you to do step one, then step two, then step three, you do not actually learn how to problem solve on your own, or even how to "think" about your problem.

    That's WHY we ask you to show what YOU have done, rather than just complaining about not having been given instant gratification with the solution to your problem. If you want to look for someone to "blame," actually look "objectively" at your first post and see if it meets the requirements I have suggested.

    NOW you say you have "read a lot" but you avoid stating what you might have actually read related to your current problem. We don't know what research you may have done on the two messages you received, if you actually did any, and we don't know if you did any on the issue of "changing the system clock" vs. "other possible solutions" to those messages.

    My advice would be to attempt to separate your "ego" from your "quest" and indicate what actually research criteria you may have investigated regarding your problem and then, maybe someone will direct you to a "better" search criteria which might lead you to your problem.

    No one actually "owes" you the answer to your problem and you would actually be better off, in the "learning" department, to be given "clues" YOU actually follow to the answer, if one exists.

    Regards,
    JMI

  6. #6
    Naides is Nobody
    Join Date
    Jan 2002
    Location
    Planet Earth
    Posts
    1,647
    The emulator fucked up.
    It is probably sending information that does not make sense to the main application.
    Your points of attack:
    The message error: Who generates it and why?
    Use the Olly conditional branch logger and trace the application under the good boy conditions (Clock back in time, program runs)
    and the bad boy conditions, clock current, error message,

    Locate where the code execution line takes the wrong turn and why.

  7. #7
    Quote Originally Posted by chefo View Post
    The new message from the program was: "Time-hasp Battery Dead!".
    Do you have a dongle plugged in? If so, does it have a battery, and can it be trying to tell you its battery is dead?

    I realize dongles can be emulated without the dongle but some people have the dongle and use emulation to bypass the on-board electronics on the dongle.

    I read this about a dongle in a pdf that I subsequently lost:

    - Contains internal battery.
    - Battery life of up to 4 years - when battery expires, lock must be
    replaced.

    Here's another from

    http://www.aladdin.com/hasp/faq_hardware.aspx:

    7. What happens when the battery dies in a HASP HL Time?

    When not connected to a computer, the HASP HL Time battery has a lifetime of four years. However, battery life can be increased to at least ten years if the key remains connected to an operating computer. When the battery eventually dies, HASP HL Time can be used as a HASP HL Max, i.e. it no longer supports time-limited licenses, but continues to provide activation-limited licenses.

    Here's something you should consider, that is typical of modern day electronic component ripoffs. Many printers today have a scam going on ink replacement. They use a chip on the ink tank, and get this: it is timed for so may usage cycles. That is, the cycle can run out before the ink runs out. Also, the old ink is collected in a drain, and it too is timed. It can shut off your printer before the overflow tank is full.

    It wouldn't surprise me in the least if the battery life in a dongle was timed, so that it could generate an error message without the dongle even being there. That, of course, would have to happen in the software.

    If you don't have a dongle plugged in, I'd go looking for that error message in the software.

  8. #8
    WaxfordSqueers:

    Since chefo reported that he can get the dongle to work if he "turns the system clock back" it certainly appears to argue against the "battery" actually being "dead." One would "assume" that if the battery were actually "dead" the dongle would not function at all.

    However, I have not attempted to research this issue myself. I'm simply attempting to apply "logic" to the statements made. It would appear that the whole point of the "time lock" would be to prevent the dongle from working if the set time for the license had expired or the battery had gone dead. But then, who said life had to be "logical."

    Regards,
    JMI

  9. #9
    Quote Originally Posted by JMI View Post
    Since chefo reported that he can get the dongle to work if he "turns the system clock back" it certainly appears to argue against the "battery" actually being "dead." One would "assume" that if the battery were actually "dead" the dongle would not function at all.
    I get your point JMI but you have to downgrade your logic to think like a corporate-type/capitalist pig.

    If the 'battery dead' error was programmed in the software, not because the battery was actually dead, but because they wanted you to think it was dead, then it would be logical, in their dementia, to terminate your services forthwith, even though the battery/dongle was still good. Rolling back the clock would possibly fix the problem because the brain-dead corporate types who think up those schemes are not quite smart enough to figure it all out. Go ask +Ork. The fact that rolling back the time gets rid of the 'battery dead' message suggests to me that is is software related.

    In the world of printers, Epson was a forerunner with the idea of putting chips on ink tanks to prevent you refilling them. The logic in the chip counted cycles of usage, however, rather than measuring how much ink was left in the tank. To me, that was cheating, but to Epson, it was no doubt considered sound business practice. The reality was that their system shut you down while there was still ink in your tanks.

    Here's another one. I bought a license from Kaspersky 'once'. After a year, my license ran out and I was told I'd need to renew. I thought "what"? Can you imagine buying a license from Msoft for Windows and having it shut down after a year with them telling you to pay another $150 to renew? Don't laugh, that was a scam with some music software goofs.

    It's not beyond belief that the dongle maker thinks along the same demented lines. They probably figure the life of a dongle battery is 4 or 5 years, and if the battery isn't dead by then, they issue the 'battery dead' message anyway. In the blurbs I included in my post, they as much as confirmed that. They said, when the battery is dead, the dongle has to be replaced. Why? When the battery runs out on my computer, or my watch, I replace the battery, not the computer or the watch.

    How would they implement a scheme to prevent you changing the battery? It would have to be by an external software means, I would think. There's no way I know of to reprogram an EEPROM in a dongle, especially when the battery is dead. It takes a one-time, relatively high-voltage spike to reprogram an EEPROM. There's no other way that can be implemented via hardware to prevent you replacing the battery. So, if the life cycle of the dongle is timed and implemented via software, then rolling back the time to a previous year could bypass the lock-out, if they hadn't thought of that.

    Here's the logic: battery dead|5 year time out = you lose sucker.

    Then again, I'm just a dumb, albeit suspicious/canny Scotsman.

  10. #10
    As "one suspicious/canny Scotsman" to another, I find no fault with your logic either, however, with a "quick" search of "Time-hasp Battery Dead," I found no mention of complaints that the dongles were spewing "false" signals that the battery was dead, when it actually wasn't.

    However, seems he should be able to trace the error message and maybe investigate the routine which calls it, and discover "why"!

    Regards,
    JMI

  11. #11
    Quote Originally Posted by JMI View Post
    However, seems he should be able to trace the error message and maybe investigate the routine which calls it, and discover "why"!Regards,
    Maybe you missed the post by naides. He seemed pretty sure the emulator had fucked up. I know dick about hasp, or dongles. I am an electronics/computer tech, though, and my gut feeling is that it's not a hardware problem if it can be reversed by moving the time back.

    I don't know if you remember my earlier posts about the Russian software for examining hard drives at a low level. The software came with a dongle and a PCI card, but someone had reversed the dongle and the dongle was not required. Also, the PCI card was only required for certain functions, so the software was able to do the job of repairing most service sector problems using just a DOS-based emulator.

  12. #12
    chefo
    Guest
    Sorry for the delay guys, I was quite occupied these days.

    Anyway, the company is sending me back home for a month to spend some time with my family


    BTW naides is right, the emulator really fucked up. Now I get the same message disregarding the system clock.

    I suppose that there is in dead a battery in the dongle or some kind of big capacitor which keeps alive the internal clock so it should be compared with the system one and block the software if the difference is significant. Just sharing thoughts...

    My appologies to everyone but I am not that good in reverse engineering or low level programming. I have some experience with PIC or single chip computers programming and that's all. My idea is to double the software to my laptop and to use it at home while not on work for training and some homework. So emulation is not a target but a tool.

    Anyway I have couple of days to solve this, otherwise - see you in a month.

    BR

    chefo
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  13. #13
    Quote Originally Posted by chefo View Post
    I suppose that there is in dead a battery in the dongle or some kind of big capacitor which keeps alive the internal clock so it should be compared with the system one and block the software if the difference is significant. Just sharing thoughts...
    wont be a cap. They are used only for instantaneous charges. For example, in older disk drives, they used a charge on a cap to retract the heads in case of a power fail.

    I read on the net that chips and batteries are often concealed behind a sticker. If you rip the sticker, they know you tampered with it. If you find the battery, you might want to try a half-tap. That means keeping the power applied with another battery while you change the battery. May be easier said than done. The dongle is probably molded and you might have to take it right apart to get at the battery.

    I doubt if they are syncing an internal clock with the system clock. In fact, I don't know why they'd use an internal clock unless they had a microcontroller on board. The battery is probably to keep things functional while the dongle is unplugged.

    I would make sure you have a really good, tight connection between your dongle and where you plug it in. Gold-plated connectors can lose several tenths of a volt and dirty/loose connectors can drop 1/2 to 1 volt easily. That's enough to mess with a digital circuit, especially if the battery is only 3 volts (or less) to start with.

Similar Threads

  1. Replies: 0
    Last Post: February 13th, 2014, 07:42
  2. how to generat "1" instead of "uncounted" license
    By joyung in forum The Newbie Forum
    Replies: 38
    Last Post: April 10th, 2012, 03:57
  3. Replies: 4
    Last Post: May 28th, 2009, 13:02
  4. Replies: 1
    Last Post: December 14th, 2007, 13:35
  5. Edit Time Hasp HL
    By papo1123 in forum The Newbie Forum
    Replies: 5
    Last Post: March 23rd, 2007, 21:12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •