Results 1 to 5 of 5

Thread: loader32 deletes my .nms file after creating it?

  1. #1
    latigo
    Guest

    loader32 deletes my .nms file after creating it?

    Hi there!
    I'm trying to build my asm project with symbolic debug under WinME but i seem to have problems..
    Aparently the debug info is inserted in the exe because the executable ends bigger after linking. But when i try to load it using either nmsym or the loader32, my .NMS file is deleted by the afore mentioned tools.

    Currently, i'm assembling with:

    \masm32\bin\ml /Cp /coff /Zi /c %1.asm

    Linking with:
    \masm32\bin\Link /SUBSYSTEM:WINDOWS /DEBUG /DEBUGTYPE:CV /LIBPATH:c:\masm32\lib %1.obj %1.res


    and trying to load my exe into softice with:

    D:\WinApps\NuMega\Winnie4.5
    msym /translate:source,package,always /source: MyProject.ASM /load:execute,break MyProject.exe

    I'm kinda desoriented :/

    Any ptr is appreciated as per usual.
    TIA.

    Latigo
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  2. #2
    rKo
    Guest
    Hi,
    You seem to be using Softice 4.5. Sadly that doesn't work with MASM. Last known working version was 3.25. But is does work with TASM.
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  3. #3
    latigo
    Guest
    duh..i'll go back to older versions of sice then..
    Thanks mate.

    Latigo
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  4. #4
    f_v_man
    Guest
    hey where can I get sice 4.5
    I promise that I have read the FAQ and tried to use the Search to answer my question.

  5. #5
    latigo
    Guest
    www.numega.com
    I promise that I have read the FAQ and tried to use the Search to answer my question.

Similar Threads

  1. Replies: 10
    Last Post: December 29th, 2008, 23:55
  2. creating win32 api == ?
    By shakuni in forum Advanced Reversing and Programming
    Replies: 6
    Last Post: May 10th, 2008, 18:45
  3. Unpacked app deletes itself
    By 5aLIVE in forum The Newbie Forum
    Replies: 35
    Last Post: October 15th, 2007, 18:35
  4. A question about creating process
    By Hero in forum Advanced Reversing and Programming
    Replies: 12
    Last Post: September 17th, 2007, 21:42
  5. Using original .idata instead of creating new section
    By doctorow in forum Malware Analysis and Unpacking Forum
    Replies: 1
    Last Post: August 22nd, 2003, 09:53

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •