PDA

View Full Version : Ollydbg Problem on XP SP2


ferrari
October 12th, 2004, 07:32
I clean installed XP SP2 and whenever I load any program in Olly I get this error:

Unable to write memory of debugged process (7FFD8002...7FFD8002)

I disabled DEP(Data Execution Prevention) as a suspect but still problem exsist.

I hope the answer isn't-> Uninstall SP2 8-P

Regards.

kittmaster
October 12th, 2004, 13:10
I'm running SP2 and have no issues at all...........I'll be curious to see what others have to say

yahia
October 13th, 2004, 08:24
ferrari : You have to give more information about more staff ..
I have SP2 but didn't face any of your troubles !
I don't think it's a bug in OllyDbg, but what you have to think about is :
1- Is your copy of WinXP legal & have no problems ?
2- Did you install a software that controls your Mem or some staff that prevent Olly from accessing memory ?
3- Do you have problems in hardware ?
4- What kinda version of OllyDbg do U use .Is it the final one ?
5- Did you currectly install OllyDbg in your system ?
6- Did you enable/disable administrative options that belongs to Olly's issue ?

Be sure that you carefully did read the above & i hope that you get your answer your self .Because I don't think that you have to uninstall SP2 .

Regards .

ferrari
October 13th, 2004, 09:17
Another member on ARTeam forum reported the same problem so I'm not the only one with this problem:

Register to view topic.

_http://intechhosting.com/~access/forums/index.php?showtopic=164


>>1- Is your copy of WinXP legal & have no problems ?

Illegal(compensate loss) coz I own legal crap Win ME and olly works on ME but not "Win XP SP2 which I slip streamed and did clean install and then problem started. Before this I installed SP2 on WinXP SP1 and Olly worked with no prob.

>>2- Did you install a software that controls your Mem or some >>staff that prevent Olly from accessing memory ?

NO coz I used Olly just after fresh install of XP SP2 and only basic softs like Office, Nero, Adobe, Zone alaram, AVG Anti virus were installed.

>>3- Do you have problems in hardware ?

No. It worked on Win ME so maybe not.

>>4- What kinda version of OllyDbg do U use .Is it the final one ?

Final

>>5- Did you currectly install OllyDbg in your system ?

Yes coz I'm using it for almost a year now so I'm sure I installed it correctly ;-).

>>6- Did you enable/disable administrative options that belongs to >>Olly's issue ?

First I was logged in as Power user and then I checked as Admin but problem persist.

---
If htere is no solution to this then I'll clean install XP SP1 and then install SP2 coz now I cannot follow the M$ KB to uninstall SP2 maybe coz I slipstreamed SP2 :-(

Hope The above info is enough

Thnx for reply

Ferrari

JDog45
October 13th, 2004, 10:56
I also have that same issue. Running a clean install of SP2, Olly 1.10

goppit
October 21st, 2004, 17:08
Hi Ferrari,

Sounds like I got similar setup to yours;

illegal XP Pro into which I slipstreamed SP2 and did clean install
AVGfree
Zonealarm
etc

I use Olly 1.10 final and I get this stupid error too
However it works OK on my old desktop running very lean installation of 98SE. M$ OS is getting worse not better. I also get new XP style BSOD at least twice a week.

If I see any info on this issue I will duplicate it here.

Kindest Regards,

Goppit.

MaRKuS TH DJM
October 24th, 2004, 08:23
it's a plugin. the Olly Helper plugin.
go to options of this plugin, and disable "Auto Clear Debug Bit". error solved. this plugin doesn't support SP2

aka
October 24th, 2004, 11:27
i copy the file Psapi.dll from OllyDbg11.zip, then run OllyDbg again and see a dialog box message which wants to overwrite the new one of XP SP2, click No.

JDog45
October 31st, 2004, 21:47
Works like a charm, thanks MaRKuS TH DJM

alper
November 21st, 2004, 12:18
MaRKuS TH DJM

markus good crack. pls give me your e-mail

regards.