PDA

View Full Version : 1.08b2 slowness


Cvx
November 13th, 2002, 12:29
This is probably not a bug.

I'm analyzing a program that uses networking and requires to stay in sync with its server.
However, when using OllyDbg 1.08b2, attaching to a running program takes much more time than it took with 1.06. The DLL-loading stuff seems to be very time consuming now. While attaching, the client program freezes and loses sync, so i can't debug it.

Loading the program from OllyDbg isn't possible, because the program needs to be started from a launcher application.

Is there any chance to speed up the attach functionality? Maybe an option to disable some DLL parsing features?

TBD
November 13th, 2002, 22:42
Cvx: your program is available on the web ? so i can test it too ...

did you tried in Options/Analysis1 to deselect Auto start analysis of main module and have selected Keep analysis between sessions ?

the ideea is to have all DLL/EXE analysed before actual debugging

Anonymous
November 15th, 2002, 07:47
to speed it up delete dbghelp.dll if u dont need it

Cvx
November 15th, 2002, 12:14
your program is available on the web ? so i can test it too ...
No, it isn't.

Auto analysis is turned off, Keep analysis is turned on.

I can (sometimes) work around the out-of-sync problem if i start the program, and attach immediately. This is somewhat time-critical, as i have to get the right moment, when no server connection is established yet.

But that doesn't work all the time, because some of the DLLs are still being loaded while connecting, and that takes ages (around 30 seconds, on a 1900+!)

TBD
November 16th, 2002, 06:00
Cvx: even if you have had analysed the DLLs before ? hmm, strange.

i cannot help me you more if i cannot test on my system to see where the problem is.

please contact me on email address, maybe we can sort it out somehow

Cvx
November 16th, 2002, 07:33
The newly released 1.08 revision seems to attach much faster. Loading the DLLs doesn't take too much time now, altough it's not as fast as 1.06. But it works fine for me now.
Thanks for your help.

Anonymous
November 16th, 2002, 10:18
Cvx: have u tried removing the dbghelp.dll if u dont need it?

Cvx
November 16th, 2002, 10:39
Yep, tried that. No difference. 1.08 attachs fast enough most of the time now, i have to stick with it i guess.

Anonymous
November 17th, 2002, 18:20
1.08 works well!