PDA

View Full Version : Why unpacked files dont run on win2k


LaptoniC
August 29th, 2001, 16:28
I have problems with Win2k.My unpacked files work on Win9x and WinMe but Win2k.What is the reason for it?.I have unpacked lastly Ulead GIF Animator 5 (vbox) with the help of revirgin.It worked on win9x but not on win2k.I have attached my revirgin output.Also revirgin changes some 00000 entries to RPCRT4.dll I_RpcBindingInqDynamicEndpointA.With these entries program dont run even in Win9x so I have deleted them.Is this is a bug ?.Thanks.

aimless
August 31st, 2001, 00:52
Unlike Win 9x, Win NT and more recently Win 2K, CHECKS the CHECKSUM/CRC of each file before execution.

If it finds a flaw, it will not work.

Then again, you could have it so because NT/2K calls files differently from Win 9X.

My guess is: Get a Checksum/CRC correcter, do the necessary and blas. It SHOULD run.

have Phun

tsehp
August 31st, 2001, 01:28
and some api names were changed, actually rv rebuilded import are guaranteed to work if you stay on the same win major+minor version, all is explained into the manual.

LaptoniC
August 31st, 2001, 09:26
I have put correct crc of file but I dont think it is the problem.Because some files without correct crc also runs on win2k.I have also tried to use Make Pe header win2k compatible command. in Peditor's rebuilder.

LaptoniC
September 9th, 2001, 11:32
I found the problem.Problem is the missing imports.In win9x some imports from mfc42.dll was missing.I have tried to use revirging on win2k.Revirgin gaved bad result ie wrong import names duplicate imports however it resolved correctly this missing imports in win9x.It is interesting.Thanks for your help.

RaX [e!]
September 13th, 2001, 11:17
it's not interesting! it's a pain in the arse!!!