PDA

View Full Version : Hasp password using windows 7 x64


newhasper
July 4th, 2013, 16:36
Hi all,
I'm trying to edit the contents of a Hasp HL key. I'm running windows 7 x64 and I havn't been able to find a utility to allow me to extract the hasp passwords.
I do have access to windows 7 x32, but the software is 64bit so I really need to find a way to extract the passwords.

I've tried Toros aladin dongles monitor, but everytime I try to install the usb filter and restart Windows does a system restore.
I've used HASPHL2010 to get a dump, but the universal hasp dump to reg converter keeps saying it has unknown size. The file size is 737 bytes.

I've a pretty good idea of the address that I need too edit in the Hasp memory, I just need the password. I've spent hours on this going round in circles. It's a shame because the tutorials and other information on crackz webpage are full of good information, it's just that the tools don't seem to be upto date.

newhasper
July 5th, 2013, 01:11
OK I think I'm onto something here. I thought I couldn't get the passwords out of HASPHL2010 because haspedit wouldn't let me put in letters when asking for the password.
I found another thread where someone was having the same problem and ended up writing a hex to decimal converter.

I converted the passwords into decimal and put them into haspedit. I got "Cannot open HASP Device Driver (-100)". I grabbed my 32bit machine, put haspedit onto that and tried again to no avail. I get the same error on the other machine.

FoxB
July 5th, 2013, 05:28
tell us the software name

newhasper
July 5th, 2013, 12:36
The dongle is for mastercam x6. Sorry I didn't think that was relevant as its an ots hasp hl.

FoxB
July 5th, 2013, 12:57
584B:4AE9 (22603:19177 decimal)
MasterCAM v7.1, v8.0, v9.0, v9.1, v10.0

newhasper
July 5th, 2013, 15:20
Quote:
[Originally Posted by FoxB;95001]584B:4AE9 (22603:19177 decimal)
MasterCAM v7.1, v8.0, v9.0, v9.1, v10.0


Yeah that's what I got. Haspedit is still giving a driver error with error code -100 though.

I've managed to get an XP machine for the weekend so I'll give it a go on that and see how I get on.

kjms
July 6th, 2013, 08:31
Save as reg, use multikey 18.2.4
Quote:
REGEDIT4
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Multikey\Dumps\584B4AE9]
"SN"=dwordEADBEEF
"Type"=dword:0000000A
"Memory"=dword:00000001
"DongleType"=Dword:00000001
"SecTable"=hex:2D,2D,03,03,ED,ED,C3,C3
"NetMemory"=hex:00,00,00,00,00,00,00,00,00,00,FF,FF
"Option"=hex:00,01,02,4A,1F,01,06,06,0D,01,0D,13,06,00
"Data"=hex:\
0F,2D,9A,D3,B1,5B,00,00,01,00,90,04,90,01,06,00,\
90,01,00,00,90,01,02,00,90,01,06,0A,90,01,02,00,\
42,35,CE,36,44,30,42,47,98,A6,CE,36,05,0A,90,01,\
90,01,00,00,00,00,00,00,00,00,00,00,00,00,FF,FF,\
FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,\
FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,\
FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF,FF

Ico747
July 8th, 2013, 04:57
Where to find multikey 18.2.4?

Woodmann
July 8th, 2013, 21:55
Quote:
Where to find multikey 18.2.4?


Ico747, Are you serious ???

Do not ask such a question again. Capice?
As a matter of fact, do not even respond to this post.

Don Wooma