PDA

View Full Version : HASP HL 3.25 (SRM?) Emulation


Znuff
April 28th, 2012, 23:35
Hello,

I'm a newbie at this thing, I've searched the forum and read most of the topics on this matter, but I have to say that I ended up more confused than I should have.

Here's my issue: I have a dongle for an application called e:cue. Problem is I travel a lot with this dongle from home to work, and I'd like to leave the dongle at home (so I don't break it...) and emulate it.

I've followed most instructions on the web. I tried with HASPHL2007 (and the EDGE tool), but to no avail (I was getting "Error 18". Maybe because I was running this in a Virtual Machine (as I couldn't use the *2007 version on my Win7 64bit).

I've managed to do .dmp files with HASPHL2010, I've also managed to do (ONCE!) a backup with h5dmp.exe (so I do have the hasp.dmp and hhl_mem.dmp files).

After that, I played around with the software with the original dongle, and I believe I managed to trigger a firmware update of some kind, because now if I try to dump the dongle again with h5dmp.exe, I get "Error(-10): Dongle not found. Plug dongle, and try again".

I've also managed to build up a reg file from hasp.dmp and hhl_mem.dmp, I've tried to use it in different ways with MultiKey, but the software simply doesn't detect anything.


Here's all the files I managed to create and what I've tried so far: http://dl.dropbox.com/u/120650/Dongle/index.html

What should I do next? I'm completely clueless at the moment after +6 hours of trying to find a solution to this.

Also, is there any possible way for me to downgrade the Dongle so I can read it again with h5dmp.exe? (I've only managed to downgrade it to 3.21, but that still doesn't fix the h5dmp.exe problem)