View Full Version : Reshacker saving in vista?

May 14th, 2008, 17:52
Hey, i was playing around with ResHacker today, editing some menu's, text strings and so on...

And i realised that whilst ResHacker said it had saved the new EXEs fine when i opened them the resources were not edited (I used compile script then file->save) and the saving seemed to be done fine but the EXEs were identical (the exe and exe_original)...

Can someone help me? is there any reason reshacker wouldn't save properly?


May 14th, 2008, 18:20
As it states in the FAQ: Tell US what YOU have done to attempt to find the answer to YOUR question. (Otherwise, you would appear too lazy to even start with your own searching for answers to such questions.)

Consider that Vista is reportedly more "secure" in it's effort in preventing "unauthorized" tampering with exe files on a Vista machine.


May 14th, 2008, 18:43
Apologies, so far i have googled for any incompatibilities with vista and it's supposed to work fine, i've also searched the forum for anything to do with reshacker on vista and i couldn't find anything related to my issue, nor any other issue in reshacker's functionality... I've also read the reshacker FAQ and help file with no luck...(but quite obviously not read the forums FAQ thoroughly i will do now)

If i re-open the file in reshacker (the edited file) it shows the modifications (e.g. the modified strings are still modified) and yet when i run the application there's no change... I did the same with a menu and it says the menu has been changed (the changes are obvious i've added text to a menu item and a accelerator key)... but when the exe is run there's no sign of change....

I'll keep trying with different ways to fix it but i don't know whats causing the problem, i thought compatibility so i've tried using vista's compatibility modes and it's made no difference... Cheers for taking the time to reply,


May 14th, 2008, 18:59
I believe you may have again failed to "focus" on the relevant subject for possible "research."

Have you considered that VISTA, not ResHacker, is the "force" preventing you from modifying the exe files???? Have YOU researched THAT issue???

Have you looked into whether or how VISTA may be preventing the modification of exe files by external processes and/or whether or not there are mechanism in VISTA designed to prevent such an event from occurring???

Did the thought even occur to you???


May 15th, 2008, 03:15
If the original exe and the (attempted) edited exe are identical in a binary comparison, as you say, isn't it extremely strange that the changes show up in ResHacker the next time you open that file, as you also say?

This would indeed indicate that you have saved the changes to the wrong place (either to the wrong exe file, or in some kind of "project file" etc).

Also, before suspecting Vista, I'd really recommend testing the exact same thing on any other operating system too, which I couldn't conclude that you had done from what you have posted so far?

May 15th, 2008, 07:17
Okay, i spent some more time last night working over the problem. It was the exe i was trying to modify not reshacker/vista, i opened it in olly and found that the menu resources were also in the data section of the program (well the strings that are displayed)... i tried using reshacker on XP and the same problem occoured, so i tried the same on a different application and it worked fine(on both XP and vista).

Cheers for taking the time to reply,