PDA

View Full Version : Security Alert Message problem


Swimmer
June 20th, 2007, 14:22
I have tried internet search and the XP newsgroup with no luck. I want to find out how to stop the message from appearing.

Could someone help me ?

Thanks.

After connection with my ISP, I get a security
alert that says:

The security certificate is from a company you have not chosen to trust.

View the certificate to see if you want to trust it.

The security certificate date is valid

The security certificate has a valid name matching the name of the
page you want to view

Do you want to proceed

Yes No View the Certificate

Thanks.

squidge
June 20th, 2007, 16:58
Well, it seems that when you connect to the internet, some program is trying to get a webpage via your browser, and your browser has been told not to serve it because of the certificate.

So I'd say the answer is to find that program and nuke it. Viewing the certificate may help in this regard.

LLXX
June 20th, 2007, 17:48
If you get that message while trying to access a webpage, just click Yes...

Swimmer
June 20th, 2007, 21:43
Thank you gentlemen for your help.

It appears to be working, but not sure what did it.

I clicked for it to accept the certificate, then I could no
longer connect with my ISP.

So I restored to an earlier date, no difference.
Tried an even earlier date, no difference.

Did a sfc on all the system files. I was gone when it finished, but didn't see any kind of message.

Now it works OK.

I think I'll get me a Lime Topo Chico

Take care.

Silver
June 22nd, 2007, 10:38
What you need to do is click View The Certificate. One of the options/tabs in there will show you the certification path - find out the issuing CA for the certificate, then get the issuing CA's cert and import it into your trusted root certificate store (using MMC - add snapin - certificates).

The problem is that your ISP (or whatever is initiating the connection) is using a self-signed cert that isn't issued by the trusted roots in your cert store. By default Windows comes with a stack of Verisign, Thawte etc root certs, which is why SSL generally "just works transparently" on your machine & in IE.

But go in your cert store and delete all your trusted certs, then go to an obviously legit SSL site (Amazon, Paypal) and you'll get the cert warning - because you don't trust the issuing CA any more.

PKI 101, this is

Swimmer
June 22nd, 2007, 11:35
I re-installed my ISP dialer program.

I get one or two script errors, which I click to get past.

I think I'll just accept that and be happy.

This was recently created and am wondering what it's purpose is.

E:\Backup\Certificate_files

It has some .gif and .js files.

Thanks.

Silver
June 23rd, 2007, 10:50
Quote:

This was recently created and am wondering what it's purpose is.

E:\Backup\Certificate_files

It has some .gif and .js files.


The only answer I can give you:

Swimmer
June 23rd, 2007, 21:21
Quote:
[Originally Posted by Silver;66638]The only answer I can give you:


I'll search through the registry for the exact file names, if nothing, then off to the recycle bin they go. :-)